Post new topic Reply to topic  [ 1 post ] 
Author Message
Team: Psionic Corps
Rank: Peon
Main: Qu'Kuu
Level: 2530

Joined: Mon Jul 13, 2009 12:16 am
Posts: 156
Post "Phantom" guns and energy costs (Multifiring)
Found an odd one, equipping multiple of a weapon on a ship causes two distinct bugs.

First, equipping the last of an unequipped weapon (i.e. 2 abstructors, equip one at a time) will leave behind an unequipped extra copy of that weapon. This copy is entirely non-interactive, attempting to equip/toss/move it will produce the error message "no such item".

In addition, the first time a multifired weapon set is fired, the energy cost will "stick".

Example: Mount 2 of a weapon, resting energy regeneration 200, regeneration while reloading the guns -150. Firing should cause regeneration to drop to -150 until the guns are ready to fire again, but for some reason, the regeneration does not go back up to 200 after the reload's done, staying at -150 and draining the whole energy bank.

I have tested this on several ships, and have confirmed the bug on all but one (Jujuso'rka, which behaved normally).

AI base weapons seem to be less buggy. Testing in a space blue gamma, I got the bug with torpedo X2, but it worked fine with 3 equipped. Hunleyite X2 worked fine. Abstructors caused the bug at 2 and 3.

This is bug persists when the ship is activated as a slave, rendering the slave unable to properly generate power.

Sat Apr 08, 2017 1:18 pm
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 2 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
Powered by phpBB © phpBB Group.